TreeDraw Legacy Edition manual

TreeDraw site SpanSoft main site

TreeDraw Legacy Edition

Getting Started

Introducing TreeDraw Legacy Edition

Tutorials

Tutorial - Importing a tree

Tutorial - Using the drawing area

Tutorial - Printing a chart

Tasks

File handling

Starting a new chart

Opening an existing chart

Saving a chart

Saving a chart with a different name

Importing trees

Selecting a Legacy database

Importing from the same file again

Exporting the chart as an Adobe PDF file

Exporting the chart as a metafile

Exporting the chart as a bitmap

Preparing the chart for sending

Dropping files into TreeDraw

Changing the Legacy database link names

Preferences | File settings

Tree import settings

Choosing import options

Preferences | Import visuals

Preferences | Import fields

Preferences | Dates

Preferences | Replace text

Preferences | Import profiles

Getting import visual styles from selection

Editing a chart

Selecting the pointer tool

Selecting chart elements

Selecting all chart elements

Adding text

Editing text

Adding lines and shapes

Adding pictures and graphics

Moving chart elements

Resizing chart elements

Joining lines to chart elements

Unjoining chart lines

Cutting to the clipboard

Copying to the clipboard

Pasting from the clipboard

Deleting chart elements

Grouping chart elements together

Ungrouping chart elements

Updating text automatically

Undoing the previous operation

Redoing the subsequent operation

Undoing several operations

Scaling the chart

Formatting

Setting text font

Setting text alignment

Setting text rotation

Setting word wrapping

Changing a text element's link to a Legacy database

Selecting a family to use in a database link

Selecting a person to use in a database link

Setting the line style

Choosing a line style

Setting the shape fill pattern

Setting colours

Repeating the last format change

Getting default styles from selection

Alignment

Changing the order of chart elements

Aligning chart elements horizontally

Aligning chart elements vertically

Spacing chart elements evenly

Centring curved lines

Screen

Using the magnifier

Enlarging text

Turning the snap-to-grid on and off

Displaying page-breaks

Using the ruler

Moving around the drawing area

Zooming in and out

Searching for text

Turning the Colour Palette on and off

Turning the Chart View Control on and off

Turning the Button Bar on and off

Customising the Button Bar

Turning the Status Bar on and off

Preferences | Appearance

Printing

Printing a chart

Selecting pages to print

Setting page size/margins/orientation/footer

Setting a user-defined paper size

Setting up the printer

General

Setting preferences

Preferences | General

Exiting from the program

Backing-up your data

Checking for program updates

Using the Chart View Control

Reference

File menu

Edit menu

Format menu

Align menu

Tools menu

View menu

Options menu

Database fields

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

Legacy

How to get support

How to contact us

Large-format printing service

Ordering / registration

Choosing import options

After a Legacy database has been loaded, you must select the root person for the tree and additional options which affect the layout of the tree.

 
Selecting the root person

TreeDraw imports a tree starting from the root person. For a descendant tree this person will be at the top and the tree will display all his/her descendants. For an ancestral tree the root person is at the bottom and the tree will display all his/her ancestors. For a wheel chart the root person is in the middle and his/her ancestors are displayed around the wheel.

The root person list allows you to find the person you want to use quickly.

If you know the RIN of the person you are looking for simply type it into the RIN box (RIN stands for Record Identification Number). As you do so the list will scroll to that person (assuming that the RIN is valid). The RINs are the same as those used in the Legacy database.

If you want to scroll through the list, first select the field which you want the list sorted by. The currently selected sort field is the one with the bold name at the top of the list. To change it, simply click on the field name you want the list sorted by.

Some sort fields allow you to enter a search string below the list which will scroll the list automatically to entries beginning with that string. For example, to go straight to all the people whose surnames begin with GO, click on "Surname" at the top of the surname column and then type GO into the "Surname" box at the bottom of the form.

The "Birth date" column will show either a person's birth or christening date depending on which is available in the Legacy data. A "b." denotes that it is a birth date and a "c." that is a christening date. Due to limitations in the Legacy database, if you select the "Birth date" column for sorting the list, all christening dates will be shown before all birth dates. Note that the "Birth place" column shows only the data from the Legacy Birth Place field, even if a christening date is displayed in the "Birth date" column. This is also due to a limitation in the Legacy database.

 
Import profile

Import profiles let you store a particular style of setup for importing trees; eg. fonts, line styles, etc. Select a profile for this tree here if you do not want to use the current settings.

 
Person details

Set this option if you want to include dates, places and other information for individuals. The data included in the person's details is defined in "Options | Preferences | Import fields | Person details".

 
Marriage details

Set this option if you want to include dates, places and other information for families. The data included in the family's details is defined in "Options | Preferences | Import fields | Marriage details". If this option is not set, the "Marriage indicator" data type is used instead of the "Marriage details" data type.

 
Events

Set this option if you want to include data from events for individuals and marriages. The data included in events is defined in "Options | Preferences | Import fields | Events".

 
Connect multi marriages

Set this option if you want to have the marriage details of people who have more than one marriage linked by a dashed line. This option is not available in Ancestral trees. The style of line used can be set in "Options | Preferences | Import visuals | Marriage line style".

 
Keep births private

Set this option if you wish to exclude the birth and christening dates of people who are still alive.

 
Private records

Set this option if you want to include people, events or addresses which have the "Private" or "Invisible" flag set against them in Legacy.

 
Group tree elements

Set this option if you wish to have associated tree elements (such as a person's name and details) automatically grouped together. This is very useful later when you will want to move the tree elements around.

 
Add statistics

Set this option if you wish to have a stamp/statistics box added at the bottom of the tree. The statistics include the name of the imported tree file, date created and number of people, families and generations. The stamp is your personalised mark which may be your name and address or whatever information you wish. To modify your stamp, see "Options | Preferences | Import visuals | Text to include in statistics box".

 
Flag duplicates

Set this option if you wish TreeDraw to check for duplicated branches (eg. where cousins have married) or invalid relationships (eg. someone is his own grandfather). "DUPLICATE" in red will be added to all people which appear more than once in the tree. TreeDraw will also truncate the tree at the duplicated person except on the first occurrence so that branches of the tree are not duplicated. If this option is not set, any invalid relationships will cause TreeDraw to loop endlessly and not complete the import.

 
Boxed

Set this option to have TreeDraw automatically put boxes around the text for descendant/ancestral trees or circles around the wheel chart. The line style and fill pattern/colour for the boxes can be set in "Options | Preferences | Import visuals".

 
Join lines

Set this option if you wish to automatically join the linking lines together.

 
Pictures

Include

Set this option if you want pictures from the Legacy database included in the tree.

 
Maximum width/height

If you are including pictures in the import, set the maximum size (in drawing area units) of the images. The aspect ratio of each picture will be preserved.

 
Must have print flag

Set this option if you wish only pictures which have their "Print" flag set to be included (the print flag is an option in Legacy for each picture) otherwise all pictures will be included.

 
Full resolution

Set this option to import the full-sized pictures directly into the chart. The pictures will still have their visible size limited by the "Maximum width/height" option but will be the same resolution as the original image. This is useful if you intend to export the chart as a PDF file for later printing. You do not need to set this option if you are sending the chart file itself for later printing (see Preparing the chart for sending).

 
All generations / Expand to ? generations

If you set All Generations, every descendant or ancestor will be included. If you require to limit the depth of the tree, clear the All Generations box and enter a number in Expand to ... generations. Entering 0 will produce a tree with only the root person, 1 will include his/her children or parents (depending on the tree type), and so on.

 
Layout

Four formats of Descendant or Ancestral tree are available and the selected layout is displayed in this box. Select Extend generations vertically if you wish children to proceed across the page and generations from top to bottom and Extend generations horizontally for the opposite arrangement. Select Align tree left (or top) to justify the tree to the left or top (depending on the Extend generations option) and Align tree centre to produce a centred tree.

For wheel charts you can include some Extra width which makes each band of the wheel wider than required by the text so that the outer bands can accommodate all the text.

See also

Download genealogy software for family history research. Our free to try genealogy software is for family history research. Download TreeDraw to print charts from Legacy Family Tree software, it is free to try. We specialize in free to try genealogy software, available for download. Try our genealogy charting software for free. You can download genealogy software for family history. TreeDraw is a charting program for your family history. Download genealogy chart program for use with Legacy Family Tree. Free 30-day trial. You can download genealogy software, free trial, to print your family history. Download genealogy software here for Legacy. This site is about genealogy and family history software with free trial software. TreeDraw imports Legacy Family Tree files and produces genealogy charts. Print family trees with our free to try genealogy software. Our family history software is free to try and is used for genealogy. Genealogy software is sometimes mispelled as geneology software. TreeDraw is a genealogy chart program, download it here.