TreeDraw Legacy Edition manual

TreeDraw site SpanSoft main site

TreeDraw Legacy Edition

Getting Started

Introducing TreeDraw Legacy Edition

Tutorials

Tutorial - Importing a tree

Tutorial - Using the drawing area

Tutorial - Printing a chart

Tasks

File handling

Starting a new chart

Opening an existing chart

Saving a chart

Saving a chart with a different name

Importing trees

Selecting a Legacy database

Importing from the same file again

Exporting the chart as an Adobe PDF file

Exporting the chart as a metafile

Exporting the chart as a bitmap

Preparing the chart for sending

Dropping files into TreeDraw

Changing the Legacy database link names

Preferences | File settings

Tree import settings

Choosing import options

Preferences | Import visuals

Preferences | Import fields

Preferences | Dates

Preferences | Replace text

Preferences | Import profiles

Getting import visual styles from selection

Editing a chart

Selecting the pointer tool

Selecting chart elements

Selecting all chart elements

Adding text

Editing text

Adding lines and shapes

Adding pictures and graphics

Moving chart elements

Resizing chart elements

Joining lines to chart elements

Unjoining chart lines

Cutting to the clipboard

Copying to the clipboard

Pasting from the clipboard

Deleting chart elements

Grouping chart elements together

Ungrouping chart elements

Updating text automatically

Undoing the previous operation

Redoing the subsequent operation

Undoing several operations

Scaling the chart

Formatting

Setting text font

Setting text alignment

Setting text rotation

Setting word wrapping

Changing a text element's link to a Legacy database

Selecting a family to use in a database link

Selecting a person to use in a database link

Setting the line style

Choosing a line style

Setting the shape fill pattern

Setting colours

Repeating the last format change

Getting default styles from selection

Alignment

Changing the order of chart elements

Aligning chart elements horizontally

Aligning chart elements vertically

Spacing chart elements evenly

Centring curved lines

Screen

Using the magnifier

Enlarging text

Turning the snap-to-grid on and off

Displaying page-breaks

Using the ruler

Moving around the drawing area

Zooming in and out

Searching for text

Turning the Colour Palette on and off

Turning the Chart View Control on and off

Turning the Button Bar on and off

Customising the Button Bar

Turning the Status Bar on and off

Preferences | Appearance

Printing

Printing a chart

Selecting pages to print

Setting page size/margins/orientation/footer

Setting a user-defined paper size

Setting up the printer

General

Setting preferences

Preferences | General

Exiting from the program

Backing-up your data

Checking for program updates

Using the Chart View Control

Reference

File menu

Edit menu

Format menu

Align menu

Tools menu

View menu

Options menu

Database fields

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

Legacy

How to get support

How to contact us

Large-format printing service

Ordering / registration

Setting page size/margins/orientation/footer

The page setup dialog allows you to format various features of the layout of printed charts. These settings are independent of the currently selected printer (if any). This allows you to select much larger page sizes than the printer will accept, for example, which is useful for exporting PDF files.

 
Printer settings

This displays the currently selected printer/port and paper source. If you want to change these, click on the Setup button.

 
Measure

You may specify margins and page sizes in either inches or millimetres. When you change from one to the other, the current values will be converted for you. TreeDraw also uses this setting for the units used by the ruler.

 
Margins

Enter the measurement for each of the page margins.

 
Orientation

Select Portrait or Landscape to suit the type of report you are printing. Note that the page margins do not change when you change the orientation, but the width and height of the page do.

 
Paper size

Select the paper size you are using from the list. The list contains a standard list of paper sizes. If you want to define a paper size which is not in the list, enter the appropriate Width and Height. The paper size in the list will change to "Custom size".

You can define extra paper sizes and add them to the paper size list. Right-click on the paper size list and choose Add. Enter a paper size name and the width & height. When the new paper name appears in the list it will be prefixed by a "*" - this identifies user-defined sizes. You can edit or delete user-defined paper sizes by right-clicking on them in the list.

 
Page footer

TreeDraw can print an optional page footer which appears at the bottom of every printed page. The footer can have a date stamp, user-defined text and the page number.

Set Include revision to include a revision stamp in the page footer. The revision stamp can include the date of printing and some text. When it's printed the footer takes the following format: <text> <date>

<text> is user defined text which may be entered in the "Text" field.

<date> is the current date and is formatted using the standard system date. The date in the footer is the date that the chart is printed, not the creation date.

Set Include page numbers to have a page number printed at the bottom of each page. You can enter the text to be printed in front of the page number in Prefix.

Note that pages numbers are formatted as <X>-<Y> where X is the horizontal page number and <Y> is the vertical page number; except where there is only one row or column of pages in the selected pages. For example, if the selected pages are 3 wide by 2 tall, the page numbers will be 1-1, 2-1, 3-1, 1-2, 2-2, 3-2.

You can choose whether the revision stamp and the page numbers are printed on the left, right or in the centre of the page. Naturally you can't have both printed in the same position.

The page footer is printed between the bottom margin and the bottom of the paper. Set the distance from the bottom of the paper that the page footer should be printed.

You can choose which font you want to use for the page footer in "Options | Preferences | Appearance".

 
Print across then down

Select this option to change the order that pages are printed in; so that the first row of pages is printed, then the next row, and so on.

 
Print down then across

Select this option to change the order that pages are printed in; so that the first column of pages is printed, then the next column, and so on.

 
Print blank pages

Select this option if you want TreeDraw to print pages which are part of the selected pages but do not have any chart elements on them.

See also

Download genealogy software here for Legacy. This site is about genealogy and family history with free trial software. We specialize in free to try genealogy software available for download. You can download genealogy software for family history. TreeDraw is a genealogy chart program for your family tree, download it here. Download genealogy chart program for use with Legacy Family Tree. Free 30-day trial. Download TreeDraw to print charts from Legacy Family Tree, it is free to try. Genealogy software is sometimes mispelled as geneology software. Print family trees using our free to try genealogy software. Download genealogy software, free trial, to print your family history. Try our genealogy charting software for free. Our genealogy software imports Legacy files and prints genealogy charts. Have you tried our free to try family tree software? Our family history software is free to try and is used for genealogy. Download genealogy software and print family trees. Download genealogy software for family history research. Our free to try genealogy software is good for family history research.