TreeDraw Legacy Edition manual

TreeDraw site SpanSoft main site

TreeDraw Legacy Edition

Getting Started

Introducing TreeDraw Legacy Edition

Tutorials

Tutorial - Importing a tree

Tutorial - Using the drawing area

Tutorial - Printing a chart

Tasks

File handling

Starting a new chart

Opening an existing chart

Saving a chart

Saving a chart with a different name

Importing trees

Selecting a Legacy database

Importing from the same file again

Exporting the chart as an Adobe PDF file

Exporting the chart as a metafile

Exporting the chart as a bitmap

Preparing the chart for sending

Dropping files into TreeDraw

Changing the Legacy database link names

Preferences | File settings

Tree import settings

Choosing import options

Preferences | Import visuals

Preferences | Import fields

Preferences | Dates

Preferences | Replace text

Preferences | Import profiles

Getting import visual styles from selection

Editing a chart

Selecting the pointer tool

Selecting chart elements

Selecting all chart elements

Adding text

Editing text

Adding lines and shapes

Adding pictures and graphics

Moving chart elements

Resizing chart elements

Joining lines to chart elements

Unjoining chart lines

Cutting to the clipboard

Copying to the clipboard

Pasting from the clipboard

Deleting chart elements

Grouping chart elements together

Ungrouping chart elements

Updating text automatically

Undoing the previous operation

Redoing the subsequent operation

Undoing several operations

Scaling the chart

Formatting

Setting text font

Setting text alignment

Setting text rotation

Setting word wrapping

Changing a text element's link to a Legacy database

Selecting a family to use in a database link

Selecting a person to use in a database link

Setting the line style

Choosing a line style

Setting the shape fill pattern

Setting colours

Repeating the last format change

Getting default styles from selection

Alignment

Changing the order of chart elements

Aligning chart elements horizontally

Aligning chart elements vertically

Spacing chart elements evenly

Centring curved lines

Screen

Using the magnifier

Enlarging text

Turning the snap-to-grid on and off

Displaying page-breaks

Using the ruler

Moving around the drawing area

Zooming in and out

Searching for text

Turning the Colour Palette on and off

Turning the Chart View Control on and off

Turning the Button Bar on and off

Customising the Button Bar

Turning the Status Bar on and off

Preferences | Appearance

Printing

Printing a chart

Selecting pages to print

Setting page size/margins/orientation/footer

Setting a user-defined paper size

Setting up the printer

General

Setting preferences

Preferences | General

Exiting from the program

Backing-up your data

Checking for program updates

Using the Chart View Control

Reference

File menu

Edit menu

Format menu

Align menu

Tools menu

View menu

Options menu

Database fields

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

Legacy

How to get support

How to contact us

Large-format printing service

Ordering / registration

Preferences | Replace text

TreeDraw has the capability to automatically find and replace selected text as it is imported. This is useful, for instance, where you may have recurring, long place names in your tree data which you want to shorten in the TreeDraw chart so as to save space (eg. replacing "Clackmannanshire" with "Clacks.").

When adding find/replace text pairs to the list it is important to decide in what order the items should appear in the "Imported text" list. TreeDraw searches an imported text element for all instances of the first item in the "Imported text" list and carries out the appropriate replacements. The program then proceeds down through the list in the same way until all replacements have been carried out to that one text element.

If the list contained, say:

replace "F/B" with "Fredericksberg" and then

replace "Frederick" with "Fred"

then the imported text "F/B" would be changed first to "Fredericksberg" and then to "Fredsberg", clearly not the desired result. Changing the list order to:

replace "Frederick" with "Fred" and then

replace "F/B" with "Fredericksberg"

produces the replacement "F/B" to "Fredricksberg", the "Frederick" not having been found on the first pass.

You can change the order of the find/replace text pairs by selecting an item in the "Imported text" list and then using the Up and Down buttons.

 
Imported text

Type the text to be replaced into the edit box at the top of the list and the text to replace it with into the Replace with box. If you want to change the "Imported text" for an existing entry in the list, you must delete the entry and add a new one.

Click on an entry in the list if you want to change its "Replace with" or "Case sensitive" settings or delete it.

 
Replace with

If you have clicked on an entry in the "Imported text" list (ie. there is a item highlighted), you can change the replacement text associated with it, just by changing the entry in this box.

 
Case sensitive

If you only want to replace text which matches exactly the upper and lower case letters of the imported text, select this option; eg. "fred" does not find "Fred" only "Fred" finds "Fred". Otherwise the function will replace all text which matches, ignoring the case; eg. "fred" finds "Fred" and "Fred" finds "Fred".

If you have clicked on an entry in the "Imported text" list (ie. there is a item highlighted), you can change the case sensitive setting associated with it, just by clicking on this option.

 
Add

Adds the current contents of the "Imported text" edit box, "Replace with" box and "Case sensitive" box to the "Imported text" list. The entry is inserted into the list before the currently selected entry. If no entry is selected then the new entry is added to the end of the list. If you want to clear the selection, right-click on the list.

 
Delete

Click on this button to remove the currently selected item from the Imported text list. If you want to change the "Imported text" part of a find/replace pair you must delete the existing entry and add a new one.

 
Replace during import

Set this option if you want the replacements to be carried out during the initial import of a tree.

 
Replace during update

Set this option if you want the replacements to be carried out during a text update.

See also

Download genealogy software for family history research. Our free to try genealogy software is for family history research. Download TreeDraw to print charts from Legacy Family Tree software, it is free to try. We specialize in free to try genealogy software, available for download. Try our genealogy charting software for free. You can download genealogy software for family history. TreeDraw is a charting program for your family history. Download genealogy chart program for use with Legacy Family Tree. Free 30-day trial. You can download genealogy software, free trial, to print your family history. Download genealogy software here for Legacy. This site is about genealogy and family history software with free trial software. TreeDraw imports Legacy Family Tree files and produces genealogy charts. Print family trees with our free to try genealogy software. Our family history software is free to try and is used for genealogy. Genealogy software is sometimes mispelled as geneology software. TreeDraw is a genealogy chart program, download it here.