TreeDraw Legacy Edition manual

TreeDraw site SpanSoft main site

TreeDraw Legacy Edition

Getting Started

Introducing TreeDraw Legacy Edition

Tutorials

Tutorial - Importing a tree

Tutorial - Using the drawing area

Tutorial - Printing a chart

Tasks

File handling

Starting a new chart

Opening an existing chart

Saving a chart

Saving a chart with a different name

Importing trees

Selecting a Legacy database

Importing from the same file again

Exporting the chart as an Adobe PDF file

Exporting the chart as a metafile

Exporting the chart as a bitmap

Preparing the chart for sending

Dropping files into TreeDraw

Changing the Legacy database link names

Preferences | File settings

Tree import settings

Choosing import options

Preferences | Import visuals

Preferences | Import fields

Preferences | Dates

Preferences | Replace text

Preferences | Import profiles

Getting import visual styles from selection

Editing a chart

Selecting the pointer tool

Selecting chart elements

Selecting all chart elements

Adding text

Editing text

Adding lines and shapes

Adding pictures and graphics

Moving chart elements

Resizing chart elements

Joining lines to chart elements

Unjoining chart lines

Cutting to the clipboard

Copying to the clipboard

Pasting from the clipboard

Deleting chart elements

Grouping chart elements together

Ungrouping chart elements

Updating text automatically

Undoing the previous operation

Redoing the subsequent operation

Undoing several operations

Scaling the chart

Formatting

Setting text font

Setting text alignment

Setting text rotation

Setting word wrapping

Changing a text element's link to a Legacy database

Selecting a family to use in a database link

Selecting a person to use in a database link

Setting the line style

Choosing a line style

Setting the shape fill pattern

Setting colours

Repeating the last format change

Getting default styles from selection

Alignment

Changing the order of chart elements

Aligning chart elements horizontally

Aligning chart elements vertically

Spacing chart elements evenly

Centring curved lines

Screen

Using the magnifier

Enlarging text

Turning the snap-to-grid on and off

Displaying page-breaks

Using the ruler

Moving around the drawing area

Zooming in and out

Searching for text

Turning the Colour Palette on and off

Turning the Chart View Control on and off

Turning the Button Bar on and off

Customising the Button Bar

Turning the Status Bar on and off

Preferences | Appearance

Printing

Printing a chart

Selecting pages to print

Setting page size/margins/orientation/footer

Setting a user-defined paper size

Setting up the printer

General

Setting preferences

Preferences | General

Exiting from the program

Backing-up your data

Checking for program updates

Using the Chart View Control

Reference

File menu

Edit menu

Format menu

Align menu

Tools menu

View menu

Options menu

Database fields

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

Legacy

How to get support

How to contact us

Large-format printing service

Ordering / registration

Preferences | File settings

File settings are a handful of TreeDraw options which are saved as part of each TreeDraw chart (.TDR file) . This means that when you re-open a chart file, these particular options will change to match those of the file. Most of these options are maintained elsewhere in TreeDraw.

 
Snap-to-grid spacing

The horizontal and vertical spacing between intersections of the snap-to-grid. Change these in "Options | Preferences | Appearance".

 
Page size/margins/orientation/footer

The page layout options. Set these in "File | Page setup".

 
Selected pages

The pages which TreeDraw will print. Use the Page selection tool to select pages. Click on the Clear button to have no pages selected; you may want to do this before using the Save settings button.

 
Auto-update text

If this option is set for the current chart, then the next time this chart file is opened TreeDraw will perform an Update text command on the entire chart.

 
Full-sized image folder

When TreeDraw imports pictures from a Legacy database, it copies a smaller version of the full-sized picture into the chart. However, the name of the original full-sized file is stored as part of the image in the chart so that when you print the chart TreeDraw can use the (better quality) full-sized image instead of the smaller image that you see on the screen.

This is OK as long as your chart (.TDR) files remain on your own PC. If you want to send a chart file to someone else, for printing on a larger format printer for example, you would also have to send the full-sized picture files from the appropriate Legacy pictures folder. Use the "File | Prepare to send" function to make copies of full-sized images files which are used by the current chart. The recipient should set the path in "Full-sized image folder" to wherever he stores your pictures files so that TreeDraw can find them.

 
Save settings

If you want TreeDraw to apply the current file settings every time you start a new chart, click on this button. All of the above settings are now your default settings for new charts.

See also

Download genealogy software for family history research. Our free to try genealogy software is for family history research. Download TreeDraw to print charts from Legacy Family Tree software, it is free to try. We specialize in free to try genealogy software, available for download. Try our genealogy charting software for free. You can download genealogy software for family history. TreeDraw is a charting program for your family history. Download genealogy chart program for use with Legacy Family Tree. Free 30-day trial. You can download genealogy software, free trial, to print your family history. Download genealogy software here for Legacy. This site is about genealogy and family history software with free trial software. TreeDraw imports Legacy Family Tree files and produces genealogy charts. Print family trees with our free to try genealogy software. Our family history software is free to try and is used for genealogy. Genealogy software is sometimes mispelled as geneology software. TreeDraw is a genealogy chart program, download it here.