TreeDraw Legacy Edition manual

TreeDraw site SpanSoft main site

TreeDraw Legacy Edition

Getting Started

Introducing TreeDraw Legacy Edition

Tutorials

Tutorial - Importing a tree

Tutorial - Using the drawing area

Tutorial - Printing a chart

Tasks

File handling

Starting a new chart

Opening an existing chart

Saving a chart

Saving a chart with a different name

Importing trees

Selecting a Legacy database

Importing from the same file again

Exporting the chart as an Adobe PDF file

Exporting the chart as a metafile

Exporting the chart as a bitmap

Preparing the chart for sending

Dropping files into TreeDraw

Changing the Legacy database link names

Preferences | File settings

Tree import settings

Choosing import options

Preferences | Import visuals

Preferences | Import fields

Preferences | Dates

Preferences | Replace text

Preferences | Import profiles

Getting import visual styles from selection

Editing a chart

Selecting the pointer tool

Selecting chart elements

Selecting all chart elements

Adding text

Editing text

Adding lines and shapes

Adding pictures and graphics

Moving chart elements

Resizing chart elements

Joining lines to chart elements

Unjoining chart lines

Cutting to the clipboard

Copying to the clipboard

Pasting from the clipboard

Deleting chart elements

Grouping chart elements together

Ungrouping chart elements

Updating text automatically

Undoing the previous operation

Redoing the subsequent operation

Undoing several operations

Scaling the chart

Formatting

Setting text font

Setting text alignment

Setting text rotation

Setting word wrapping

Changing a text element's link to a Legacy database

Selecting a family to use in a database link

Selecting a person to use in a database link

Setting the line style

Choosing a line style

Setting the shape fill pattern

Setting colours

Repeating the last format change

Getting default styles from selection

Alignment

Changing the order of chart elements

Aligning chart elements horizontally

Aligning chart elements vertically

Spacing chart elements evenly

Centring curved lines

Screen

Using the magnifier

Enlarging text

Turning the snap-to-grid on and off

Displaying page-breaks

Using the ruler

Moving around the drawing area

Zooming in and out

Searching for text

Turning the Colour Palette on and off

Turning the Chart View Control on and off

Turning the Button Bar on and off

Customising the Button Bar

Turning the Status Bar on and off

Preferences | Appearance

Printing

Printing a chart

Selecting pages to print

Setting page size/margins/orientation/footer

Setting a user-defined paper size

Setting up the printer

General

Setting preferences

Preferences | General

Exiting from the program

Backing-up your data

Checking for program updates

Using the Chart View Control

Reference

File menu

Edit menu

Format menu

Align menu

Tools menu

View menu

Options menu

Database fields

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

Legacy

How to get support

How to contact us

Large-format printing service

Ordering / registration

Exporting the chart as an Adobe PDF file

Exports the selected pages as an Adobe PDF file which can be viewed by anyone using the Adobe Acrobat Reader. Free copies of the Acrobat Reader can be downloaded from the Adobe Web site at www.adobe.com

TreeDraw produces PDF V1.4 files which require Acrobat Reader V5 or later.

The following settings and options can be set.

 
File

Select the folder to save the PDF file in and enter a file name. The file will automatically be given a .pdf extension if the file type is set to "Adobe PDF files".

 
Info

These entries will be embedded in the PDF file and can be viewed by using "File | Document Properties | Summary" in the Acrobat Reader.

 
Options

Compression - determines the final size of the PDF file by using different methods for compressing the file.

Encode binary - converts the text to binary instead of ASCII.

Show mode - determines how the PDF file will first be displayed when opened in Acrobat.

Fonts mode - the following settings are available.

Use TrueType Fonts - uses TrueType fonts but does not embed the font data in the PDF file.

Embed TrueType Fonts - embed data of all used fonts. Ensures that text displays correctly in the reader even if the fonts do not exist on the reader's PC but makes the PDF file large.

Embed only Symbol TrueType Fonts - embed only symbol true type fonts. (eg. WingDings, etc)

Use 14 Base Type1 Fonts - Do not use true type. When this mode is selected you can only use Arial, Courier New and Times New Roman fonts.

TTF Subsets: only used codepages - will embed all the characters which are used in the codepage (character set) you selected.

TTF Subsets: only used chars - includes only the characters which have been used and so produces the smallest files.

Full sized images - determines whether TreeDraw exports images from the TreeDraw .TDR chart file or from the original full-sized image files (if available). If this option is selected and a full-sized image file does not exist, TreeDraw will use the internal image anyway.

Create thumbnails - creates thumbnails for each page of the PDF file. Note that Acrobat V5 or later automatically creates thumbnails if none are present anyway so this option is really for backwards compatibility.

Launch Acrobat Reader - automatically opens the new PDF file in the Acrobat Reader. You must have the reader installed for this to work.

 
Security

Encrypt PDF file - set this option to make the PDF file secure using the following settings.

Owner password - password required to edit the PDF file. If left blank a random password will be allocated.

User password - password required to read the PDF file. If left blank no password is required but you can still restrict printing/copying/changing below.

Use 128 bit security - 128 bit security is better but slower.

Enable printing - allows the reader to print the PDF file.

Enable copying - allows the reader to copy text from the PDF file.

Enable change - allows the reader to change the PDF file.

See also

You can download genealogy software here. It's free to try and is used for genealogy. Download genealogy software to print family trees. Download genealogy software from SpanSoft for Legacy Family Tree. This site is about genealogy and family history software with free trial software. We specialize in free to try genealogy software, available for download. Download genealogy software for family history. Download charting program for printing your family history. Free 30-day trial. TreeDraw is a genealogy chart program for use with Legacy Family Tree. Download genealogy software and print your family tree. Genealogy software is sometimes mispelled as geneology software but we spell it genealogy software. You can download genealogy software, free trial, to print your family history. Try our genealogy charting software for free. TreeDraw imports Legacy Family Tree files and produces genealogy charts. Family trees can be printed using our free to try genealogy software. Download genealogy software to print charts from Legacy, it is free to try. Download genealogy software for family history research. Our free to try genealogy software is good for family history research.