TreeDraw Legacy Edition manual

TreeDraw site SpanSoft main site

TreeDraw Legacy Edition

Getting Started

Introducing TreeDraw Legacy Edition

Tutorials

Tutorial - Importing a tree

Tutorial - Using the drawing area

Tutorial - Printing a chart

Tasks

File handling

Starting a new chart

Opening an existing chart

Saving a chart

Saving a chart with a different name

Importing trees

Selecting a Legacy database

Importing from the same file again

Exporting the chart as an Adobe PDF file

Exporting the chart as a metafile

Exporting the chart as a bitmap

Preparing the chart for sending

Dropping files into TreeDraw

Changing the Legacy database link names

Preferences | File settings

Tree import settings

Choosing import options

Preferences | Import visuals

Preferences | Import fields

Preferences | Dates

Preferences | Replace text

Preferences | Import profiles

Getting import visual styles from selection

Editing a chart

Selecting the pointer tool

Selecting chart elements

Selecting all chart elements

Adding text

Editing text

Adding lines and shapes

Adding pictures and graphics

Moving chart elements

Resizing chart elements

Joining lines to chart elements

Unjoining chart lines

Cutting to the clipboard

Copying to the clipboard

Pasting from the clipboard

Deleting chart elements

Grouping chart elements together

Ungrouping chart elements

Updating text automatically

Undoing the previous operation

Redoing the subsequent operation

Undoing several operations

Scaling the chart

Formatting

Setting text font

Setting text alignment

Setting text rotation

Setting word wrapping

Changing a text element's link to a Legacy database

Selecting a family to use in a database link

Selecting a person to use in a database link

Setting the line style

Choosing a line style

Setting the shape fill pattern

Setting colours

Repeating the last format change

Getting default styles from selection

Alignment

Changing the order of chart elements

Aligning chart elements horizontally

Aligning chart elements vertically

Spacing chart elements evenly

Centring curved lines

Screen

Using the magnifier

Enlarging text

Turning the snap-to-grid on and off

Displaying page-breaks

Using the ruler

Moving around the drawing area

Zooming in and out

Searching for text

Turning the Colour Palette on and off

Turning the Chart View Control on and off

Turning the Button Bar on and off

Customising the Button Bar

Turning the Status Bar on and off

Preferences | Appearance

Printing

Printing a chart

Selecting pages to print

Setting page size/margins/orientation/footer

Setting a user-defined paper size

Setting up the printer

General

Setting preferences

Preferences | General

Exiting from the program

Backing-up your data

Checking for program updates

Using the Chart View Control

Reference

File menu

Edit menu

Format menu

Align menu

Tools menu

View menu

Options menu

Database fields

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

Legacy

How to get support

How to contact us

Large-format printing service

Ordering / registration

Tutorial - Importing a tree

This tutorial requires the sample Legacy family file supplied with the program "TreeDrawSample.fdb"

Subjects: Setting import options, importing a tree.

TreeDraw Legacy Edition is designed to import data from Legacy databases only.

 
There are several stages required to import a tree.

1) Set up the standard import options such as which pieces of data you want, the line styles, fonts, etc. These options remain set until you change them again.

2) Select the type of tree you want; descendant, ancestral or wheel.

3) Select the data source, a Legacy family file name.

4) Select the person who will form the root of the tree, tree layout and other options.

 
1) Setting up the standard import options

Before importing your first tree you should check, and modify if necessary, the standard options which tell TreeDraw how to import data. The following settings affect an imported chart...

 
Graphical settings

Click on "Options | Preferences | Import visuals" to open the preferences dialog at the "Import visuals" page. This is where you set the style of text, lines, etc used when a tree is imported.

 
Fonts

Click on the appropriate Change button to change the font used for person names, person details or marriage details. The chart will look best if you have all of these fonts the same size but you can make them different if you wish. Changing the fonts here does not change the default font in "Format | Font" for manually added text.

 
Text alignment

Click on "Left", "Centre" or "Right" to change the justification of the imported text. This setting also affects how TreeDraw aligns the individual parts of a person/details block.

 
Word wrapping

Click on "Word wrap" to change whether TreeDraw should automatically break long lines of text at a space between words. Setting the word wrapping to ON is usually best.

You can also set the maximum width for wrapped text by clicking on "Wrapped text width". Wrapped text elements can always have their width changed later manually by resizing the element but it is useful to be able to limit the width whilst the tree is being import to reduce the overall size of the tree.

 
Statistics stamp

You can add your own personalised text to the statistics box in an imported tree in "Text to include in statistics box". If you do not want any additional text, delete all the text in the stamp box.

 
Line styles and colour

TreeDraw uses two types of line when importing a tree. "Normal" lines connect parents to children and "Marriage" lines are only used where a person has more than one marriage. To change the line style, width or colour of a particular type of line, click on the appropriate "Change" button to open the Line style dialog. Changing the line styles here does not change the default line style in "Format | Line style" for manually added lines.

 
Box style and colour

If you intend to have your drop-line trees "boxed" (ie. with boxes around the text) or if you are importing a wheel chart, you can use the "Box style" settings to choose the style and colour of the boxes. Click on the "Outline" button to change the line style or colour of the box outline. Choose the fill pattern from the "Pattern" list. Note that the bottom pattern in the list is "solid" and the next one up is "clear". To change the colour of the box fill, click on the "Fill colour" button. A sample of the selected settings will be shown in the box above this button.

 
Date format

You can choose how TreeDraw formats imported dates; it does not matter what format the original date was in. Click on the Dates tab in the Preferences dialog and choose a format from the "Date format" list. You can also change the separator and whether a leading zero should be used for day/month numbers less than 10.

If you want to change the month and weekday descriptions (into another language for instance), just click on each description in turn and type in the new entry.

As you change the date format options, you can see how dates will look in the two samples.

If you are working with dates prior to 1752 you should set the Gregorian calendar adoption date correctly. This is the date on which the Julian calendar was replaced with the Gregorian one; in Great Britain this was in 1752 but other countries changed on different dates. Setting this option will make TreeDraw work out the day-of-the-week correctly.

 
Replacement text

TreeDraw has the capability to automatically find and replace selected text as it is imported. This is useful, for instance, where you may have recurring, long place names in your tree data which you want to shorten in the TreeDraw chart so as to save space (eg. replacing "Clackmannanshire" with "Clacks.").

Click on the Replace text tab in the Preferences dialog to add replacements. By default there are no replacements set up.

 
Import fields

These settings tell TreeDraw which data fields to put where when importing a tree. You can also define which indicators (b., d., m., etc) to use. Click on the Import fields tab in the Preferences dialog to change these settings.

 
Snap to grid

The snap-to-grid feature is probably on already but if it is not, click on "Options | Snap to grid" so that the icon beside the menu command is depressed. Turning the grid on before importing a tree makes all the new chart elements snap to the grid and all the lines start and end at a grid intersection. This makes it easier to move the elements around after the tree has been imported.

 
2) Selecting the tree type

To begin importing a tree you can click on "File | Import | Descendant tree" for a tree which starts from a specified ancestor and moves forwards through his/her descendants; "File | Import | Ancestral tree" for a tree which starts from a specified descendant and moves backwards through his/her ancestors or "File | Import | Wheel chart" for a round chart with a specified person in the centre and his/her ancestors radiating outwards in a wheel. Note that ancestral trees and wheel charts only include the direct ancestors; there are no aunts, uncles, cousins, etc. For this tutorial click on "File | Import | Descendant tree".

 
3) Selecting the data source

You will then be asked for the name of the Legacy family file that you want to import the tree from. If "TreeDrawSample.fdb" does not appear in the list of files, click on the drop-down arrow to the right of the "Look in" box and navigate to the folder "My Documents\Legacy Family Tree\Data". Click on "TreeDrawSample.fdb" in the list of files and click on the Open button.

 
4) Selecting the root person, tree layout and options

You will now see a dialog titled "Import descendant tree from TreeDrawSample.fdb". The list at the top shows all the people in this Legacy data file.

The "Layout" box tells TreeDraw which format to use for the new tree. Practice clicking on "Vertically", "Horizontally", "Left (or Top)" and "Centre". Notice that the little diagram changes to show you what the tree will look like. Set "Extend generations" to "Vertically" and "Align tree" to "Centre".

The "Root person" list at the top of the dialog is currently sorted by surname. If you want to change the sort order, you can click on any of the column headings. The current order is indicated by a bold heading. Practice changing the sort order. When importing data from a Legacy database, the "RIN" column shows the person codes used in the database (RIN stands for Record Identification Number). Some sorted columns allow you to enter a search string at the below the list which will scroll the list automatically to entries beginning with that string. For example, to go straight to all the people whose surnames begin with GO, click on "Surname" at the top of the surname column and then type GO into the "Surname" box at the bottom of the form. We want the descendant tree to start from Thomas GORDON [P7] so type "7" into the "RIN" box and click on the OK button.

(Also in this dialog are options which tell TreeDraw what to include in this particular import operation; leave these as they are for this tutorial.)

Because the snap-to-grid feature is switched on, you will now be asked if you want TreeDraw to change the vertical spacing of the grid so that it matches the import names font. Answer Yes. This makes the vertical space between text elements the same as the linespacing of a multi-line text element and so separate elements appear to be continuous.

After a moment, TreeDraw displays the new tree in the drawing area. Notice that all the new chart elements have small, grey squares around them. This indicates that the elements are currently selected. TreeDraw always selects all of the newly imported tree and nothing else after an import. This allows you to move the new tree around easily if required.

 
Next tutorial - Using the drawing area

See also

Download genealogy software for family history research. Our free to try genealogy software is for family history research. Download TreeDraw to print charts from Legacy Family Tree software, it is free to try. We specialize in free to try genealogy software, available for download. Try our genealogy charting software for free. You can download genealogy software for family history. TreeDraw is a charting program for your family history. Download genealogy chart program for use with Legacy Family Tree. Free 30-day trial. You can download genealogy software, free trial, to print your family history. Download genealogy software here for Legacy. This site is about genealogy and family history software with free trial software. TreeDraw imports Legacy Family Tree files and produces genealogy charts. Print family trees with our free to try genealogy software. Our family history software is free to try and is used for genealogy. Genealogy software is sometimes mispelled as geneology software. TreeDraw is a genealogy chart program, download it here.