TreeDraw Legacy Edition manual

TreeDraw site SpanSoft main site

TreeDraw Legacy Edition

Getting Started

Introducing TreeDraw Legacy Edition

Tutorials

Tutorial - Importing a tree

Tutorial - Using the drawing area

Tutorial - Printing a chart

Tasks

File handling

Starting a new chart

Opening an existing chart

Saving a chart

Saving a chart with a different name

Importing trees

Selecting a Legacy database

Importing from the same file again

Exporting the chart as an Adobe PDF file

Exporting the chart as a metafile

Exporting the chart as a bitmap

Preparing the chart for sending

Dropping files into TreeDraw

Changing the Legacy database link names

Preferences | File settings

Tree import settings

Choosing import options

Preferences | Import visuals

Preferences | Import fields

Preferences | Dates

Preferences | Replace text

Preferences | Import profiles

Getting import visual styles from selection

Editing a chart

Selecting the pointer tool

Selecting chart elements

Selecting all chart elements

Adding text

Editing text

Adding lines and shapes

Adding pictures and graphics

Moving chart elements

Resizing chart elements

Joining lines to chart elements

Unjoining chart lines

Cutting to the clipboard

Copying to the clipboard

Pasting from the clipboard

Deleting chart elements

Grouping chart elements together

Ungrouping chart elements

Updating text automatically

Undoing the previous operation

Redoing the subsequent operation

Undoing several operations

Scaling the chart

Formatting

Setting text font

Setting text alignment

Setting text rotation

Setting word wrapping

Changing a text element's link to a Legacy database

Selecting a family to use in a database link

Selecting a person to use in a database link

Setting the line style

Choosing a line style

Setting the shape fill pattern

Setting colours

Repeating the last format change

Getting default styles from selection

Alignment

Changing the order of chart elements

Aligning chart elements horizontally

Aligning chart elements vertically

Spacing chart elements evenly

Centring curved lines

Screen

Using the magnifier

Enlarging text

Turning the snap-to-grid on and off

Displaying page-breaks

Using the ruler

Moving around the drawing area

Zooming in and out

Searching for text

Turning the Colour Palette on and off

Turning the Chart View Control on and off

Turning the Button Bar on and off

Customising the Button Bar

Turning the Status Bar on and off

Preferences | Appearance

Printing

Printing a chart

Selecting pages to print

Setting page size/margins/orientation/footer

Setting a user-defined paper size

Setting up the printer

General

Setting preferences

Preferences | General

Exiting from the program

Backing-up your data

Checking for program updates

Using the Chart View Control

Reference

File menu

Edit menu

Format menu

Align menu

Tools menu

View menu

Options menu

Database fields

System requirements

Frequently asked questions

Version information

Terms of use

Glossary

Legacy

How to get support

How to contact us

Large-format printing service

Ordering / registration

Frequently asked questions

Q How can I produce output from TreeDraw which is suitable for sending to a commercial printers for printing?
A Most commercial print shops now accept both PDF and PostScript files (please check that your print shop will accept them).
PDF files are for use with Adobe's Acrobat Reader and can be printed out from any PC which has the Acrobat Reader. Use "File | Export | PDF file" to export the chart as a PDF file. This is probably the best format for sending to a commercial printers because they will be able to set their own page size before printing the chart from Acrobat Reader.
PostScript files are in a standard format which contain all the information required for printing on PostScript compatible printers. To produce a PostScript file from TreeDraw you will need the generic PostScript printer driver available from the Adobe Web site at www.adobe.com. Install this driver onto your PC in the normal way but when asked for the name of the port which the printer is connected to, use "FILE". Now in TreeDraw use "File | Print setup" and select the PostScript driver; then print from TreeDraw as you would normally; you will be asked for a filename for the PostScript file (give it a .PS extension). Your print shop will now be able to print direct from the new .PS file.
 
Q I have tried to change the fill pattern of a simple graphic but nothing seems to have happened.
A The default fill colour is white so on a white background the pattern will be invisible. Use the colour palette to change the fill colour.
 
Q I have selected text from an imported tree to change its font but TreeDraw will only let me modify the default font.
A Make sure that the text you have selected is not part of a group element. You can spot this easily by looking at the Ungroup button on the button bar. If the button is enabled the element you have selected is a group. Select the Ungroup button then re-select the text element you want to modify.
 
Q I have added a rectangle around my chart but now all I can see is the rectangle; the chart has disappeared.
A The default fill for simple graphics such as a rectangle is solid white. The rectangle you have added has been placed on top of all the existing chart elements and since it's opaque it has hidden everything else. Use the Send to back command to place the rectangle behind the other elements.
 
Q How can I zoom in on a particular part of the drawing area?
A Before zooming in, first select a chart element to zoom in on. TreeDraw will zoom in and scroll to the selected element.
 
Q I want to use a very small font for importing a tree but when I use the Options|Names font command the smallest font size available is 8 point.
A You are not restricted to the font sizes supplied in the list. These are just the most frequently used sizes, you can actually enter any (supported) font size you like , such as 4 point, in the edit portion of the size list (click on the edit box at the top of the list).
 
Q Why are characters missed out at page breaks when I print to my laser printer?
A Some printers, lasers in particular, cannot print partial characters and so where a character is partially off the page, the printer will discard it altogether. You should turn on the Page Breaks display and move all the text elements away from the page breaks. This will look better if you are going to join pages together later.
 
Q How can I print out the entire help file?
A Open the file TreeDraw.PDF. This file will open in the Adobe Acrobat Reader and you will be able to print the help manual from there. If you do not have a copy of the Acrobat Reader installed on your PC you can download it for free from www.adobe.com

Download genealogy software for family history research. Our free to try genealogy software is for family history research. Download TreeDraw to print charts from Legacy Family Tree software, it is free to try. We specialize in free to try genealogy software, available for download. Try our genealogy charting software for free. You can download genealogy software for family history. TreeDraw is a charting program for your family history. Download genealogy chart program for use with Legacy Family Tree. Free 30-day trial. You can download genealogy software, free trial, to print your family history. Download genealogy software here for Legacy. This site is about genealogy and family history software with free trial software. TreeDraw imports Legacy Family Tree files and produces genealogy charts. Print family trees with our free to try genealogy software. Our family history software is free to try and is used for genealogy. Genealogy software is sometimes mispelled as geneology software. TreeDraw is a genealogy chart program, download it here.